Généralités

Cette application est la mise en pratique opérationnelle du tutoriel :

Mémento sur la programmation en VBA pour EXCEL 2010

Tome 4 : Un algorithme de chiffrement / déchiffrement des cellules pour une meilleure confidentialité

Publié sur le site

Auteurs : CryptoVBA : Laurent OTT - Documentation : Gaby277

L'application CryptoVBA permet de chiffrer / déchiffrer, une ou des plages de cellules de fichiers Excel pour protéger des données sensibles.

Mais également un fichier complet Excel et des fichiers d'autres types (.docx, .txt, ...).

En outre le contenu (texte) du presse-papier, peut également être chiffré / déchiffré et utilisé dans toutes les applications qui y ont accès.

Il existe une version pour Excel 97 (CryptoVBA.xls) et pour Excel 2010 en 32 bits compatible 2016 (CryptoVBA.xlsm) (2).

Nota 1 : l'objectif de ce fichier d'aide est d'aider l'utilisateur pour les opérations de chiffrage / déchiffrage, pas d'apprendre / comprendre comment cela est réalisé (pour cela il y a le tutoriel).

Nota 2 : la plupart des informations de ce fichier d'aide sont également valables pour le fichier "Addins" CryptoVBA.xlam cf. D'autres façons d'utiliser CryptoVBA

(2) compatibilité Excel 64 bits non disponible au 24/06/17

Créé avec HelpNDoc Personal Edition: Générateur d'aide complet


Principe

Généralités ››

Le fichier CryptoVBA.xlsm (Excel 2010 compatible 2016) ou CryptoVBA.xls (versions Excel 97) est distribué à ceux qui auront à chiffrer / déchiffrer.

Après lancement, il ajoute automatiquement une barre d'outils personnalisée (dans l'onglet compléments du ruban) qui va permettre la gestion des clés ou du mot de passe, le chiffrage / déchiffrage d'une plage de cellules, d'un fichier et du presse-papier.

Après avoir lancé ce fichier, le "Chiffreur" crée une nouvelle clé (ou en sélectionne une existante) ou saisit un mot de passe cf. Clé ou mot de passe , chiffre puis adresse le fichier crypté au(x) destinataire(s) et lui (leur) fait parvenir par un moyen sécurisé la clé utilisée ou le mot de passe.

Le "Déchiffreur" lance le fichier CryptoVBA, intègre la clé qui lui a été adressée ou saisit le mot de passe et déchiffre.

Une même clé peut être utilisée pour autant de chiffrages / déchiffrages que l'utilisateur le souhaite.

Comme pour les mots de passe, il convient d'en changer périodiquement.

Il est aussi possible de chiffrer / déchiffrer à partir d'un fichier Excel quelconque moyennant le lancement automatique de CryptoVBA.xlsm à l'ouverture d'Excel cf. Disponibilité permanente du chiffrage / déchiffrage

Créé avec HelpNDoc Personal Edition: Sites web iPhone faciles


Guide d'utilisation de CryptoVBA.xlsm

Dans ce chapitre est décrit le chiffrage / déchiffrage à partir du fichier CryptoVBA.xlsm. C'est la méthode la plus simple et celle par laquelle il convient de commencer, pour se familiariser avec le chiffrage / déchiffrage. Pour une utilisation occasionnelle (ou pas), on pourra d'ailleurs s'en contenter. En tout état de cause, ce qui est décrit ici, sera également utilisé dans les autres méthodes décrites plus loin.

La différence fondamentale de ces autres méthodes est qu'on chiffre directement à partir du classeur (à chiffrer / déchiffrer) sans avoir à passer par CryptoVBA.xlsm (c'est en réalité ce qui se produit, mais c'est transparent).

- Disponibilité permanente chiffrage / déchiffrage

C'est la principale et la plus intéressante méthode alternative et la mieux adaptée à une utilisation intensive :

CryptoVBA.xlsm est lancé automatiquement à l'ouverture d'Excel.

- D'autres façons d'utiliser CryptoVBA

Elles intéresseront sans doute plus l'informaticien, qui y découvrira de nombreuses fonctionnalités de VBA, que l'utilisateur du chiffrage déchiffrage.

Créé avec HelpNDoc Personal Edition: Créer des fichiers d'aide pour la plateforme Qt Help


Prérequis

Guide d'utilisation de CryptoVBA.xlsm ››

Si on se cantonne à chiffrer /déchiffrer :

Mais ce serait dommage...

- un PC sous Windows avec Excel 32 bits (1);

- le fichier CryptoVBA.xlsm;

- le présent fichier d'aide CryptoVBA.chm.

Pour comprendre et apprendre comment tout cela fonctionne :

Le tutoriel de Laurent OTT : Mémento sur la programmation en VBA pour EXCEL Tome 4 : Un algorithme de chiffrement / déchiffrement des cellules pour une meilleure confidentialité.

Et le fichier d'exemples : Démo_Tome4.xlsm.

Si on s’intéresse à la création du fichier d'aide :

Le fichier projet de l'aide CryptoVBA.hnd.

Et bien sûr si on n'a pas (peu) de connaissances en Visual Basic pour Applications :

Les tomes 1, 2 ,3 Mémento sur la programmation en VBA pour EXCEL qui permettent un démarrage de zéro.

Liens de téléchargement :

À télécharger sur Developpez.com.

(1) compatibilité Excel 64 bits non disponible au 24/06/2017.

Créé avec HelpNDoc Personal Edition: Créer des fichiers d'aide pour la plateforme Qt Help


Installation

Guide d'utilisation de CryptoVBA.xlsm ››

Il y a plusieurs possibilités d'utilisation de CryptoVBA.

Comme déjà indiqué, la plus simple et immédiate :

Avec CryptoVBA.xls (Version Excel 97) ou CryptoVBA.xlsm (version Excel 2010 compatible 2016).

Il n'y a pas d'installation proprement dite, il suffit de copier le fichier dans, par exemple, MesDocuments\Excel.

Pour faciliter son lancement, on peut créer un raccourci sur le bureau ou l'épingler à la liste des fichiers récents.

Toutes les opérations de Chiffrage / déchiffrage seront lancées à partir de l'onglet Compléments du ruban de CryptoVBA.

Pour une utilisation fréquente :

Provoquer le lancement automatique de CryptoVBA.xlsm à chaque démarrage d'Excel : Les fonctions de chiffrage / déchiffrage seront alors très simplement disponibles dans n'importe quel autre fichier Excel. Consulter Disponibilité permanente chiffrage/déchiffrage

Pour les geek ou des besoins particuliers :

Quelques connaissances informatiques sont souhaitables.

En utilisant le fichier CryptoVBA.xlam de macros complémentaires (1), il contient le code de chiffrage / déchiffrage de CryptoVBA.xls ou .xlsm.

Pour cela il faut rendre disponibles les macros de CryptoVBA dans le fichier que l'on veut chiffrer / déchiffrer en le "référençant". Consulter D'autres façons d'utiliser CryptoVBA.

(1) autres dénominations : complément, addins.

Créé avec HelpNDoc Personal Edition: Créer des fichiers d'aide Qt Help multi-plateformes


Le menu Chiffrage / déchiffrage

Guide d'utilisation de CryptoVBA.xlsm ››

Après lancement du fichier CryptoVBA une nouvelle barre d'outils est ajoutée dans l'onglet Compléments du ruban :

Les outils sont décrits dans Les outils disponibles

Nota : pour faciliter l'utilisation de cette application, il est conseillé d'avoir le ruban visualisé en permanence.

Si nécessaire cliquez sur l’icône (onglet Accueil sélectionné) :

(Un nouvel appui permet de replier le ruban).

Créé avec HelpNDoc Personal Edition: Produire facilement des livres électroniques Kindle


Les outils disponibles

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ››

Tous les outils pour le chiffrage / déchiffrage sont regroupés dans l'onglet Compléments du ruban.

  • Clé ou mot de passe
  • Gestion des clés
  • Visualiser les clés disponibles
  • Clé pour le chiffrage
  • Clé pour le déchiffrage
  • Mot de passe
  • Chiffrer / déchiffrer des cellules
  • Chiffrer un fichier
  • Déchiffrer un fichier
  • Chiffrer / déchiffrer le presse-papier
  • Visualiser cellule
  • Quitter le chiffrage / déchiffrage
  • Interrompre un traitement

Créé avec HelpNDoc Personal Edition: Créer des livres électroniques facilement


Clé ou mot de passe

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Le chiffrage / déchiffrage est toujours effectué avec une clé. Les clés sont stockées dans l'application. En fonction du contexte (bureau individuel, Open Space) l’utilisateur du PC est le seul administrateur du PC et il est protégé par un mot de passe robuste, ou au contraire il est simple utilisateur et un administrateur à accès à tous les fichiers, le risque de fuite d'une clé de cryptage est plus ou moins important.

Pour pallier ce risque, il est possible d'utiliser un mot de passe, qui sera saisi avant une opération de chiffrage / déchiffrage. Bien sûr se posera le problème comme pour tous les mots de passe de sa mémorisation ou conservation d'une façon sécurisée (gestionnaire de mots de passe, coffre-fort électronique).

L'avantage du mot de passe est qu'il n'est présent dans le PC que pendant les opérations de chiffrage / déchiffrage (en mémoire vive et pas dans un fichier du disque dur).

L'utilisateur peut utiliser clé ou mot de passe en appréciant le compromis sécurité / facilité d'utilisation.

Au lancement de CryptoVBA le mode Crypto "Clé" est sélectionné.

Nota 1 : en interne le mot de passe est transformé en clé fugitive pour les traitements.

Nota 2 : quand le contenu de cellules est crypté avec une clé leur contenu est transformé en "####" alors que quand il l'est avec un mot de passe leur contenu est transformé en "@@@".

Créé avec HelpNDoc Personal Edition: Outils facile d'utilisation pour créer des aides HTML et des sites web


Choisir clé ou mot de passe

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ›› Clé ou mot de passe ››

On clique sur l'option choisie :

Si on a choisi Utiliser une Clé :

Le nom de la clé qui va être utilisée est indiqué entre crochets. Dans la copie d'écran ci-dessus c'est "(CryptoVBA)"

Nota: CryptoVBA est le nom de la clé qui est créé automatiquement au lancement de l'application ou lorsque l'utilisateur a supprimé toutes les autres clés.

Si on a choisi Utiliser un Mot de passe :

Ce dernier est demandé :

Il sera utilisé pour les opérations de chiffrage / déchiffrage à venir (jusqu'à la fermeture de CryptoVBA) ou saisie d'un nouveau mot de passe, pour cela cliquez sur :

Créé avec HelpNDoc Personal Edition: Sites web iPhone faciles


Gestion des clés

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Les libellés du menu se suffisent à eux-mêmes.

Les items du menu (Communiquer la clé, Modifier le nom de la clé, Supprimer définitivement la clé) agiront sur la clé dont le nom est entre crochets [CytoVBa] dans la copie d'écran ci-dessus.

Nota :

  • Le nom d’une même clé (même valeur numérique) dans deux postes de travail peut être identique ou différent ;
  • Une même valeur de clé ne peut pas avoir deux noms différents dans l'application.

Créé avec HelpNDoc Personal Edition: Écrire des livres électroniques ePub pour l'iPad


Visualiser les clés disponibles

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Les clés disponibles peuvent être visualisées :

  • soit en cliquant sur l’icône clé (la méthode Crypto clé étant active)

  • soit en cliquant sur

Gestion des clés -> Utilisez une autre clé pour chiffrer et déchiffrer

Dans les deux cas le formulaire contenant la liste des clés est affiché :

Cliquez sur Annuler.

Pour les Geek les clés peuvent également être visualisées en affichant la feuille "clés" cf. Pour les curieux

Créé avec HelpNDoc Personal Edition: Générateur de documentations PDF gratuit


Clé pour le chiffrage

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Si le mode clé est sélectionné, la clé "active", c'est à dire celle qui sera utilisée pour le prochain chiffrage, est affichée :

Maclé va être utilisée pour le prochain chiffrage.

Si cette clé ne convient pas il est possible :

  • d'en choisir une autre, lorsqu'il y a plusieurs clés disponibles, pour cela deux possibilités :

    • La première :

Ici 4 clés sont disponibles, après clic sur la clé Maclé elle devient active et sera utilisée pour le prochain chiffrage :

    • La deuxième en cliquant sur Gestion des clés -> Utilisez une autre clé pour chiffrer et déchiffrer

  • d'en créer une autre cf. Gestion des clés

Créé avec HelpNDoc Personal Edition: Générateur complet d'aides multi-formats


Clé pour le déchiffrage

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Le nom de la clé ou le mot de passe qui a été utilisé pour le chiffrage est inclus dans le fichier crypté.

Si cryptage avec une clé :

La bonne clé sera automatiquement sélectionnée et utilisée pour le décryptage, sous réserve qu'elle ait été intégrée dans l'application au préalable avec :

Si cela n'est pas le cas, cliquez sur Ajouter une clé qui vous a été communiquée

Si cryptage avec un mot de passe :

Il faut au préalable saisir le mot de passe utilisé. à défaut un message d'erreur invitera à le faire.

Pour saisir le mot de passe cf. Choisir clé ou mot de passe

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide facilement


Mot de passe

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Comme déjà indiqué (cf. Clé ou mot de passe ) le mot de passe est demandé lorsque l'on sélectionne la Méthode crypto "Utiliser un mot de passe".

Pour un déchiffrage si le mot de passe ne correspond pas à celui utilisé pour le chiffrage, un message d'erreur est visualisé.

Contrairement au mode clé ou le nom de la clé qui a été utilisée pour un chiffrage est affiché, il n'en est rien pour le mot de passe. Il faut donc le mémoriser, pour pouvoir le communiquer pour le déchiffrage.

Attention :

Si on chiffre un fichier, le fichier non chiffré est conservé donc pas de risque de perte, par contre si on chiffre des cellules avec un mot de passe, une fois cryptoVBA fermé, si on a oublié le mot de passe, il n'y a aucune possibilité pour déchiffrer.

Créé avec HelpNDoc Personal Edition: Création d'aide CHM, PDF, DOC et HTML d'une même source


Chiffrer / déchiffrer des cellules

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Il faut ouvrir le fichier contenant les cellules à chiffrer (Fichier -> Ouvrir ou Fichier -> Récent).

Choisir le mode Crypto (mot de passe ou clé) ou conserver celui sélectionné.

Si mot de passe : saisir le mot de passe, si cela n'a pas déjà était fait.

Si clé : choisir une clé, ou clé par défaut s'il n'y en a qu'une - cf. Clé pour le chiffrage

Sélectionner les cellules à chiffrer,

Cliquer sur chiffrer ou déchiffrer la sélection.

Nota :

Un chiffrement en cours peut-être interrompu puis abandonné par l'utilisateur cf. Interrompre un traitement

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques Kindle


Chiffrer un fichier

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Comme indiqué dans Clé pour le chiffrage (mode Crypto = clé) une clé doit être sélectionnée avant de pouvoir chiffrer un fichier ou un mot de passe saisi (mode Crypto = mot de passe) cf. Choisir clé ou mot de passe

Puis cliquez sur Chiffrer / Déchiffrer un fichier.

Un sélecteur de fichier permet de choisir le fichier à chiffrer.

Après validation le cryptage s’effectue.

Le pourcentage d'avancement et l'évaluation du temps avant achèvement du chiffrage sont alors affichés.

Attention : Si le fichier est volumineux, la durée du chiffrage peut être longue.

Nota :

  • Les fichiers chiffrés sont identifiés par leur suffixe : ".Crypt"
  • Un chiffrement en cours peut-être interrompu puis abandonné par l'utilisateur cf. Interrompre un traitement

Créé avec HelpNDoc Personal Edition: Créer des fichiers d'aide Qt Help multi-plateformes


Déchiffrer un fichier

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Sélectionner le mode Crypto (clé ou mot de passe) correspondant au mode utilisé pour le chiffrage.

Suivant le mode :

Saisir le mot de passe

Si la clé est présente dans la liste des clés, elle sera automatiquement utilisée (sinon il faut l'intégrer dans l'application cf. Clé pour le déchiffrage )

Un sélecteur de fichier permet de choisir le fichier à déchiffrer.

Après validation le cryptage s’effectue.

Le pourcentage d'avancement et l'évaluation du temps avant achèvement du déchiffrage sont alors affichés.

Nota :

  • Les fichiers chiffrés sont identifiés par leur suffixe : ".Crypt"
  • Un déchiffrement en cours peut-être interrompu puis abandonné par l'utilisateur cf. Interrompre un traitement

Créé avec HelpNDoc Personal Edition: Générer des livres électroniques EPub facilement


Chiffrer / déchiffrer le presse-papier

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Permet de chiffrer / déchiffrer le contenu texte du presse-papier (pas les images, fichiers etc..) et de coller le contenu chiffré dans toutes les applications qui ont accès au presse-papier.

Par exemple une partie d'un fichier Word, le contenu d'un mail.

Nota 1 :

Un chiffrement / déchiffrement en cours peut-être interrompu puis abandonné par l'utilisateur cf. Interrompre un traitement

Nota 2 :

Comme pour des cellules ou fichiers, le mode Crypto peut-être clé ou mot de passe

Créé avec HelpNDoc Personal Edition: Écrire des livres électronique Kindle


Visualiser une cellule

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Permet de visualiser la clé de chiffrage et le contenu d'une cellule chiffrée dans un message.

La cellule reste cryptée.

Comme pour tout déchiffrage où la clé utilisée doit être disponible (ou intégrée au préalable) ou le mot de passe saisi.

Créé avec HelpNDoc Personal Edition: Nouvelles et informations sur les outils de logiciels de création d'aide


Quitter le chiffrage / déchiffrage

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

Cet item ferme le fichier CryptoVBA. La barre d'outils Chiffrage / Déchiffrage est désinstallée.

Créé avec HelpNDoc Personal Edition: Produire des aides en ligne pour les applications Qt


Aide chiffrage / déchiffrage

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ›› Les outils disponibles ››

L'aide personnalisée est un "manuel utilisateur" pour les fonctions de chiffrage / déchiffrage

Elle peut-être affichée par le bouton :

Créé avec HelpNDoc Personal Edition: Générateur de documentation Qt Help gratuit


Interrompre un traitement

Guide d'utilisation de CryptoVBA.xlsm ›› Le menu Chiffrage / déchiffrage ››

Maintenir les touches Maj + Fin enfoncées jusqu'au message de confirmation.

Créé avec HelpNDoc Personal Edition: Produire des aides en ligne pour les applications Qt


Disponibilité permanente du chiffrage / déchiffrage

Si l'on utilise souvent le chiffrage / déchiffrage, il peut être contraignant d'avoir à ouvrir systématiquement CryptoVBA.xlsm pour chiffrer / déchiffrer un autre classeur. Mais Il est possible d'avoir accès aux fonctions de chiffrage / déchiffrage depuis n'importe quel fichier (classeur Excel).

Pour cela :

- provoquer le lancement automatique de CryptoVBA.xlsm à chaque lancement d'Excel cf. Comment procéder

- cliquer sur le bouton "CryptoVBA" (situé dans l'onglet complément) qui est automatiquement créé par CryptoVBA.xlsm dans chaque fichier ouvert dans Excel.

Le lancement automatique de CryptoVBA.xlsm à chaque lancement d'Excel peut-être annulé avec :

Nota : il est possible de supprimer le message d'information qui indique comment accéder aux fonctions de chiffrement / déchiffrement :

Pour cela :

Créé avec HelpNDoc Personal Edition: Générateur complet d'aides multi-formats


Comment procéder

Disponibilité permanente du chiffrage / déchiffrage ››

Il faut mettre CryptoVBA.xlsm dans le répertoire « démarrer » d’EXCEL nommé XLSTART,

Cela peut être réalisé très simplement :

Une fois pour toutes lancer CryptoVBA.xslm, à partir d'un répertoire quelconque, puis dans l'onglet compléments, liste déroulante « gestion des clés » cliquez sur « Lancer automatiquement CryptoVBA à l’ouverture d’EXCEL ». Un formulaire s’ouvre, puis validez le message de confirmation :

Nota :

- il est aussi possible de copier CryptoVBA.xlsm dans le répertoire .....\XLSTAR avec l'explorateur de fichier.

Suivant la version de Windows et d’EXCEL, XLSTART peut se situer dans différents chemins.

Par la suite, l’ouverture d’EXCEL lancera automatiquement CryptoVBA, que vous pourrez activer en cliquant sur le bouton « CryptoVBA » dans la barre de menu personnelle « Compléments » :

Ce démarrage systématique de CryptoVBA.xlsm, pourra être annulé en utilisant le menu « Gestion des clés » puis « Ne plus lancer automatiquement CryptoVBA à l’ouverture d’EXCEL ». Le fichier CryptoVBA.xlsm sera déplacé du dossier de lancement automatique d’EXCEL dans le dossier de votre choix.

Astuce pour les geeks :
Pour connaître le chemin de XLStart dans la fenêtré d’exécution de Visual Basic (Ctrl+G) saisir :
? application.StartupPath

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


Améliorer la sécurité des fichiers partagés

Par nature, les fichiers partagés sur un réseau sont plus vulnérables. Malgré le chiffrage des cellules, un utilisateur distrait ou malintentionné, peut notamment effacer une cellule chiffrée, la déplacer, voire copier une ancienne cellule et la coller à la place d’une autre.

Pour limiter ces risques il est possible pour :

  • L'utilisateur chiffreur :

De mettre un mot de passe pour enregistrer le fichier : menu « Enregistrer sous », dans la liste déroulante

Outils -> Options générales -> saisir un mot de passe pour la modification.

  • L'utilisateur lecteur / déchiffreur en cas de doute :

De demander la valeur de la clé (ou du mot de passe) qui a servi a chiffrer et comparer avec la clé ou le mot de passe actuel. Pour cela Gestion des clés -> Sélectionner les cellules chiffrées avec la clé active (ou Sélectionner… si chiffrage avec un mot de passe).

Crypto : clé

Les cellules sont sélectionnées et la valeur de la clé est indiquée (et est copiée dans le presse-papier).

Crypto : mot de passe

Les cellules sont sélectionnées et la valeur de la clé du mot de passe est indiquée (et est copiée dans le presse papier)

  • L'administrateur :

Sur le réseau partagé de n’habiliter en lecture-écriture que les utilisateurs qui ont besoin de chiffrer les données.

Nota :

Les fichiers non partagés peuvent aussi bénéficier de ces méthodes.

Créé avec HelpNDoc Personal Edition: Produire des livres électroniques facilement


D'autres façons d'utiliser CryptoVBA

Pour approfondir les possibilités de VBA (ou adapter l'application à des besoins particuliers), il est possible d'utiliser CryptoVBA avec du code Visual Basic pour Applications. Sous réserve d'avoir un minimum de connaissances en VBA.

Plusieurs méthodes sont décrites dans le tutoriel à l’Annexe 4 : "Utiliser CryptoVBA à partir d'un autre projet"

Notamment avec CryptoVBA.xlam qui est un fichier de macros-complémentaires (aussi appelé "addins" ou complément). Une fois ce fichier référencé dans un autre classeur Excel, toutes les macros de CryptoVBA.xlam peuvent y être utilisées. Les macros disponibles dans CryptoVBA.xlam sont un sous-ensemble de celles de CryptoVBA.xlsm (le chiffrage / déchiffrage du presse-papier par exemple n'est pas repris). De nombreux exemples de code d'appel des sub et macros de CryptoVBA sont disponibles dans Démo_Tome4 .xlsm.

Cette possibilité et les autres ne sont citées ici que pour mémoire, et peu détaillées ici pour ne pas "doublonner" avec le tutoriel.

Les autres méthodes qui intéresseront sans doute plus l'informaticien que l'utilisateur :

Elles montrent toutes comment utiliser des sub (ou macros) de CryptoVBA (.xlsm ou .xlam) à partir d'un un autre classeur. Celui où justement on a des besoins de chiffrage déchiffrage

- La 1ère façon (utilisation de CryptoVBA.xlsm) :

En ouvrant le fichier CryptoVBA.xlsm qui, dans cet exemple pour chiffrer des cellules, est situé dans le répertoire du classeur appelant. La clé de chiffrement est passée en argument de la méthode Run.

- La 2ème façon (utilisation de l'addins) :

CryptoVBA.xlam est référencé par menu de l’éditeur VBA.

- La 3ème façon (utilisation de l'addins) :

CryptoVBA.xlam est référencé par du code VBA.

- La 4ème façon (utilisation de l'addins - non décrite dans le tutoriel) :

Créer CryptoVBA.xlam à partir de CryptoVBA.xlsm (sans modifier quoi que soit).

Après avoir référencé manuellement CryptoVBA.xlam, installer le menu de cryptage avec Exécuter Sub/userForm (F5) de Visual Basic.

La spécificité de cette méthode est qu'elle ne nécessite pas l'écriture de code. Tout est fait avec les menus existants.

Créé avec HelpNDoc Personal Edition: Générateur de documentation iPhone gratuit


Création du fichier d'aide personnalisée

Le présent fichier étant un composant d'un tutoriel Excel, sa création est ici décrite succinctement, pour les lecteurs qui seraient intéressés par l'ajout d'un fichier d'aide à une application Excel.

Le fichier a été créé avec

Ce logiciel est gratuit pour une utilisation personnelle. Il est léger ~ 21 Mo.

Il est très facile à prendre en main. HTMLWorkshop de Microsoft (également gratuit) doit être installé sur le PC pour compiler le fichier d'aide.

A partir du même fichier source de nombreux format d'aide peuvent être générés

Windows CHM, de la documentation WEB, des web-sites spécifiques iPhone , des documents PDF et Word, des livres eBooks aux formats ePub et Kindle ainsi que des fichiers d'aide multi-plateforme Qt Help.

La version gratuite ne comporte que très peu de limitations (de très discrets watermark).

Pour le développeur il peut générer du "code" utilisable pour l'appel de l'aide qui peut être intégré dans différents langages.

Par exemple pour le présent fichier, la liste des constantes pour visualiser un topic de l'aide

' Project: CryptoVBA

' Generated by HelpNDoc - http://www.helpndoc.com

public const HELP_Generalites as integer = 0

public const HELP_Principe as integer = 1

public const HELP_GuidedutilisationdecryptoVBAxlsm as integer = 3

public const HELP_Prerequis as integer = 16

public const HELP_Installation as integer = 8

public const HELP_LemenuChiffragedechiffrage as integer = 4

public const HELP_Lesoutilsdisponibles as integer = 5

public const HELP_Cleoumotdepasse as integer = 26

public const HELP_Choisircleoumotdepasse as integer = 28

public const HELP_Gestiondescles as integer = 2

public const HELP_Visualiserlesclesdisponibles as integer = 12

public const HELP_Clepourlechiffrage as integer = 9

public const HELP_Clepourledechiffrage as integer = 10

public const HELP_Motdepasse as integer = 21

public const HELP_Chiffrerdechiffrerdescellules as integer = 14

public const HELP_Chiffrerunfichier as integer = 11

public const HELP_Dechiffrerunfichier as integer = 13

public const HELP_Chiffrerdechiffrerlepressepapier as integer = 18

public const HELP_Visualisercellule as integer = 19

public const HELP_Quitterlechiffragedechiffrage as integer = 20

public const HELP_Aidechiffragedechiffrage as integer = 7

public const HELP_Interrompreuntraitement as integer = 17

public const HELP_Disponibilitepermanenteduchiffra as integer = 25

public const HELP_Commentproceder as integer = 27

public const HELP_DautresfaconsdutilisercryptoVBA as integer = 24

public const HELP_Creationdufichierdaidepersonnali as integer = 15

public const HELP_Appelaidepersonnalisee as integer = 6

public const HELP_Pourlescurieux as integer = 23

Créé avec HelpNDoc Personal Edition: Créer des sites web d'aide facilement


Appel aide personnalisée

Création du fichier d'aide personnalisée ››

Code VBA pour ouvrir l'aide

Avec :

1- un bouton de UserForm ou feuille de calcul (non implémenté dans CryptoVba) :

Sur clic d'un bouton

Private Sub cmdAidePersonalise_Click()

'le fichier d'aide personalisée est : CryptoVBA.chm

Application.Help ThisWorkbook.Path & "\CryptoVBA.chm", 0

' parametre 0 -> ouverture sur Toc (table of contents = table des matières)

' si parametre 2 -> ouverture du topic 2 de l'aide)

Endsub

2- F1 (non implémenté dans CryptoVBA) :

Private Sub Workbook_Open()

' Appel de l'aide personalisée avec touche F1 (au lieu de l'aide Excel)

Application.OnKey "{F1}", "AidePersonalisee"

End Sub

Sub AidePersonalisee()

'Application.Help ThisWorkbook.Path & "\CryptoVBA.chm", 0

Application.Help NomCompletFichierAide, 0

End Sub

On peut paramétrer le nom du fichier d'aide

'Dans un module :

Public Const FICHIER_CHM = "CryptoVBA.chm"

Function NomCompletFichierAide() As String

NomCompletFichierAide = ThisWorkbook.Path & "\" & FICHIER_CHM

End Function

Nota :Appel de l'aide Ecel avec un bouton de UserForm ou feuille de calcul (non implémenté dans CryptoVBA)

Private Sub cmdHelpExcel_Click()

Application.Help

End Sub

Nota: il semble difficile (en tout cas je n'ai pas trouvé) de passer de F1 -> aide Excel à F1 -> aide personnalisée et réciproquement.

Par contre on peut toujours avoir un bouton pour aide Excel et un bouton pour aide personnalisée.

Application.OnKey "{F1}" qui est sensé rétablir la fonction normale de F1 ne marche pas (l'aide personnalisée n'est plus appelée mais l'aide Excel n'est pas appelée).

3- un bouton d'un barre d'outils personalisée (implémenté dans cryptoVBA) :

Regarder le code VBA de cette application et notamment le module crypto_Menu et les sub :

  • Public Sub InstallerMenuCrypto()

...

Call MenuAjouter(msoControlButton, "Besoin d'aide", "Ouvre le fichier d'aide", "OuvrirAide", 49)

....

  • Private Sub OuvrirAide()

  • Private Sub MenuAjouter(TypeMenu As MsoControlType, NomMenu As String, _

ByVal ElémentMenu As String, ProcédureLiée As String, Optional IconeMenu As Long = 0)

Créé avec HelpNDoc Personal Edition: Créer des fichiers d'aide pour la plateforme Qt Help


Pour les curieux

La feuille de calcul contenant les clés et la feuille accueil sont masquées par confidentialité.

Pour les rendre visibles :

Affichage -> Afficher -> CryptoVBA.xlsm (ou CryptoVBA.xlsm)- > Ok

-> la feuille Accueil est maintenant visible.

Pour la feuille clés :

Lancer l'éditeur VBA (Alt+F11) ou Onglet Developpeur -> icône tout à gauche Visual basic.

nota : Si l'onglet Développeur n'est pas visible

    1. Cliquez sur l’onglet Fichier;
    2. Cliquez sur Options;
    3. Cliquez sur Personnaliser le ruban;
    4. Sous Personnaliser le ruban et Onglets principaux, activez la case à cocher Développeur.

Dans VBA : sélectionner la feuille 2 (clés).

Puis F4 (ou Affichage -> Fenêtre propriétés)

Pour la propriété Visible sélectionner -1 -xlSheetVisible

Les deux feuilles sont maintenant visibles.

Il est recommandé après consultation de les rendre à nouveau invisibles.

nota : Puisque nous parlons de rendre visible/invisible une feuille, il y a deux autres emplacements qui gèrent la visibilité des feuilles. Pour mémoire :

Accueil -> Format -> masquer & afficher -> afficher la feuille

Mais aussi clic droit sur le nom de la feuille

-> masquer.

Créé avec HelpNDoc Personal Edition: Créer de la documentation iPhone facilement